Custom Yardi Integration - Pricing
Incident Report for RentTango
Resolved
This incident has been resolved.
Posted Nov 22, 2022 - 20:49 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 22, 2022 - 18:21 UTC
This incident affected: Main App.